$re = '~\b((?:[A-Z][a-z][-A-Za-z\']*(?: *[A-Z][a-z][-A-Za-z\']*)*)\b|\b(?:[A-Z][a-z][-A-Za-z\']*))\b~';
$str = 'McDonald\'s
Ear-Resistable Designs Plus More.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);