re = /\b((?:[A-Z][a-z][-A-Za-z']*(?: *[A-Z][a-z][-A-Za-z']*)*)\b|\b(?:[A-Z][a-z][-A-Za-z']*))\b/
str = 'McDonald\'s
Ear-Resistable Designs Plus More.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end