const regex = /(jpg|jpeg|gif|png)((\?.*)$|$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(jpg|jpeg|gif|png)((\\?.*)$|$)', 'mg')
const str = `https://images.company.com/img/800X450/vehicle/201610/858823_589_1475572549658.gif?bg=000000&wmi=n
http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.jpeg?bg=000000&wmi=n&pne=ur
http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.png
http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.pngg
http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.giff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}