# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(jpg|jpeg|gif|png)((\?.*)$|$)"
test_str = ("https://images.company.com/img/800X450/vehicle/201610/858823_589_1475572549658.gif?bg=000000&wmi=n\n\n"
"http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.jpeg?bg=000000&wmi=n&pne=ur\n\n"
"http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.png\n\n"
"http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.pngg\n\n"
"http://images.company.com/img/800X450/vehicle/201610/858823_599_1475572549658.giff")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.