#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).{3}[^\s-].{3}"
Local $sString = "E4A5Y8E" & @CRLF & _
"JQIU56G" & @CRLF & _
"S91ED8F" & @CRLF & _
"ZZ9850H" & @CRLF & _
"ZPPMYA9" & @CRLF & _
"J2OXGG0" & @CRLF & _
"X0E 0S0" & @CRLF & _
"9CF0ZJG" & @CRLF & _
"LTZTBLL" & @CRLF & _
"TEZPPN7" & @CRLF & _
"UD1UBM9" & @CRLF & _
"TII6VD6" & @CRLF & _
"BMZ90JF" & @CRLF & _
"VE6NLYJ" & @CRLF & _
"VACU01D" & @CRLF & _
"8SUDAFE" & @CRLF & _
"RQ8EFOI" & @CRLF & _
"08C97PD" & @CRLF & _
"3LB58FW" & @CRLF & _
"XQC2RW9" & @CRLF & _
"HEJ79FK" & @CRLF & _
"5FEJ81D" & @CRLF & _
"149EW6B" & @CRLF & _
"9KSPVLH" & @CRLF & _
"LTUNC3S" & @CRLF & _
"HN50KLO" & @CRLF & _
"8NXO6VL" & @CRLF & _
"4AZIQB8" & @CRLF & _
"U3L0TMV" & @CRLF & _
"044V0UG" & @CRLF & _
"EICE3TP" & @CRLF & _
"7Q7SC7Z" & @CRLF & _
"L86UAT3" & @CRLF & _
"JQYQLW0" & @CRLF & _
"MOEJCMZ" & @CRLF & _
"1AGVGOO" & @CRLF & _
"MPO18T0" & @CRLF & _
"QJMJ5TN" & @CRLF & _
"XJUEMLC" & @CRLF & _
"8JOANNN" & @CRLF & _
"0FIIIA1" & @CRLF & _
"QXZN03D" & @CRLF & _
"WAM 4BI" & @CRLF & _
"R0A 0S0" & @CRLF & _
"XUNFEAD" & @CRLF & _
"2KLDUOC" & @CRLF & _
"RHG NMK" & @CRLF & _
"M0P0XQS" & @CRLF & _
"D4J8MMC" & @CRLF & _
"X0E-1C0" & @CRLF & _
"J5L1KKU" & @CRLF & _
"EI2JTNY" & @CRLF & _
"BQ5LL52" & @CRLF & _
"1G6IL0L" & @CRLF & _
"JNF7KGE" & @CRLF & _
"1U1HSTG" & @CRLF & _
"OVJIO0H" & @CRLF & _
"U7X0ZTO" & @CRLF & _
"V98C18U" & @CRLF & _
"MNPDFAA" & @CRLF & _
"JRYV6I1" & @CRLF & _
"CSU29TX" & @CRLF & _
"2YLCS0E" & @CRLF & _
"IIPIOSN" & @CRLF & _
"V4W-1B9" & @CRLF & _
"U7HUEWN" & @CRLF & _
"AKUVDLL" & @CRLF & _
"IL2H9H3" & @CRLF & _
"G3ON4LY" & @CRLF & _
"V4W 1A4" & @CRLF & _
"UZSR5YK" & @CRLF & _
"SDC2A06" & @CRLF & _
"IEZJCH3" & @CRLF & _
"UABPVDJ" & @CRLF & _
"NBXDBQ5" & @CRLF & _
"17HR851" & @CRLF & _
"E1CZAGC" & @CRLF & _
"WFJ72DU" & @CRLF & _
"ANZ0JXG" & @CRLF & _
"YHA9M3X" & @CRLF & _
"HMDV5ER" & @CRLF & _
"S3PTFHM" & @CRLF & _
"ZZ6WYSA" & @CRLF & _
"IY99JD8" & @CRLF & _
"P7UVP4Z" & @CRLF & _
"NQ283P9" & @CRLF & _
"LELIDPT" & @CRLF & _
"R6M 0A5" & @CRLF & _
"R0G 0B2" & @CRLF & _
"9MI2DV0" & @CRLF & _
"MWACX9X" & @CRLF & _
"X0E 0H0" & @CRLF & _
"I7GHXN8" & @CRLF & _
"E063NU0" & @CRLF & _
"DLV7WF6" & @CRLF & _
"5ZTM1LL" & @CRLF & _
"QMEFANR" & @CRLF & _
"CYNVB4S" & @CRLF & _
"8W2LHCK" & @CRLF & _
"V4W 0A4" & @CRLF & _
"HCRQ4GZ" & @CRLF & _
"LIJCLYP" & @CRLF & _
"OECYFT4" & @CRLF & _
"V4W 1B6" & @CRLF & _
"7SRZUGW" & @CRLF & _
"VBUHQ3B" & @CRLF & _
"J5YST0B" & @CRLF & _
"R6M 0A3" & @CRLF & _
"0OQCULR" & @CRLF & _
"BG7JIMT" & @CRLF & _
"M0JFKE7" & @CRLF & _
"J6LAMJ9" & @CRLF & _
"WNRUDD1" & @CRLF & _
"7OOZITH" & @CRLF & _
"3ML8MD3" & @CRLF & _
"94IPNLE" & @CRLF & _
"W55SJH0" & @CRLF & _
"81XXMCE" & @CRLF & _
"97JZS9U" & @CRLF & _
"NXB31OU" & @CRLF & _
"Y4EDFZ1" & @CRLF & _
"9NGKXLW" & @CRLF & _
"JJ7X46J" & @CRLF & _
"CWU3CJM" & @CRLF & _
"8D9OYOP" & @CRLF & _
"3ZZV975" & @CRLF & _
"HTVJV1C" & @CRLF & _
"MENOU7S" & @CRLF & _
"SRKBGUN" & @CRLF & _
"0MONC6T" & @CRLF & _
"MS6O469" & @CRLF & _
"IUVOYQ9" & @CRLF & _
"25RDXZV" & @CRLF & _
"D99LO98" & @CRLF & _
"GKK3H2O" & @CRLF & _
"PDHJD5B" & @CRLF & _
"2KM3K5W" & @CRLF & _
"AJIIK4L" & @CRLF & _
"BD9A24I" & @CRLF & _
"UU32Y03" & @CRLF & _
"RCA4C86" & @CRLF & _
"0H4BBVG" & @CRLF & _
"8355956" & @CRLF & _
"V4W 1A7" & @CRLF & _
"RW9JLNP" & @CRLF & _
"ZQ2YMH0" & @CRLF & _
"71YCQRC" & @CRLF & _
"4ZUNJ7Q" & @CRLF & _
"152REQB" & @CRLF & _
"4NQR40P" & @CRLF & _
"6310AX1" & @CRLF & _
"3QC0AL6" & @CRLF & _
"8HN6COW" & @CRLF & _
"R5R1SW7" & @CRLF & _
"B8NPGEX" & @CRLF & _
"0ITC8M5" & @CRLF & _
"TE09NQX" & @CRLF & _
"DCDUSQU" & @CRLF & _
"61JDWMA" & @CRLF & _
"X0E 0B0" & @CRLF & _
"V4W 1A5" & @CRLF & _
"R0G 1C0" & @CRLF & _
"Z05290B" & @CRLF & _
"SDFDJB7" & @CRLF & _
"1AIQYRC" & @CRLF & _
"F5Q3TO4" & @CRLF & _
"ABWG8R7" & @CRLF & _
"8BHF4J5" & @CRLF & _
"176AKXX" & @CRLF & _
"U12T0US" & @CRLF & _
"6AO46QD" & @CRLF & _
"XQNEDH4" & @CRLF & _
"R0G 0B0" & @CRLF & _
"4HDUV2H" & @CRLF & _
"6M3F27U" & @CRLF & _
"900YSOA" & @CRLF & _
"QZKU6WK" & @CRLF & _
"O85SHCL" & @CRLF & _
"NG6K7CE" & @CRLF & _
"47BOY8N" & @CRLF & _
"7PU2R3W" & @CRLF & _
"2UQ CIC" & @CRLF & _
"1WJ7V4F" & @CRLF & _
"QKPWPZV" & @CRLF & _
"VHVVXJT" & @CRLF & _
"7YTZW6D" & @CRLF & _
"609X0LY" & @CRLF & _
"R6M 0A6" & @CRLF & _
"3QA1UTG" & @CRLF & _
"P4NP0VS" & @CRLF & _
"8RTG25F" & @CRLF & _
"2V7KTWW" & @CRLF & _
"31FC5QQ" & @CRLF & _
"R0G 0Z0" & @CRLF & _
"V4W 1B8" & @CRLF & _
"MZ337WC" & @CRLF & _
"6BM4ASC" & @CRLF & _
"QXSKH3R" & @CRLF & _
"I0Q63JL" & @CRLF & _
"73QEDO9" & @CRLF & _
"MIPJB4E" & @CRLF & _
"5211K66" & @CRLF & _
"4PVXK85" & @CRLF & _
"DN1NRBS" & @CRLF & _
"RCKEAST" & @CRLF & _
"8PAFPN0" & @CRLF & _
"AMDE4EM" & @CRLF & _
"5RX2U4F" & @CRLF & _
"CXC4HGU" & @CRLF & _
"UJZAE15" & @CRLF & _
"JMUL6Q6" & @CRLF & _
"VI7T9R4" & @CRLF & _
"SJF31CG" & @CRLF & _
"L5R8RQB" & @CRLF & _
"CQ74GTH" & @CRLF & _
"B5B26SC" & @CRLF & _
"V4W 1C8" & @CRLF & _
"002XEHG" & @CRLF & _
"UIVMXD3" & @CRLF & _
"59U220R" & @CRLF & _
"R6M-0A1" & @CRLF & _
"LASUZGV" & @CRLF & _
"9N984BZ" & @CRLF & _
"X0YAXJ7" & @CRLF & _
"NU55569" & @CRLF & _
"G6CMXRU" & @CRLF & _
"INI41IE" & @CRLF & _
"R0A 0L0" & @CRLF & _
"EDOLTZT" & @CRLF & _
"0ZJ2JOI" & @CRLF & _
"J1LFVQP" & @CRLF & _
"IBHW7BH" & @CRLF & _
"I7LMSXR" & @CRLF & _
"V4W 1A3" & @CRLF & _
"2OQJYMM" & @CRLF & _
"8TSW5J1" & @CRLF & _
"EQ6OIPV" & @CRLF & _
"34CVVKW" & @CRLF & _
"RCAY7SH" & @CRLF & _
"V4W 1A8" & @CRLF & _
"YSXBLN0" & @CRLF & _
"G26XHHE" & @CRLF & _
"V4W 0A5" & @CRLF & _
"DIBM8LW" & @CRLF & _
"T0E4Z3N" & @CRLF & _
"X031ZWH" & @CRLF & _
"Y33IVCB" & @CRLF & _
"S9R58C4" & @CRLF & _
"TC3Q07B" & @CRLF & _
"NBYVGSB" & @CRLF & _
"V4W 1C4" & @CRLF & _
"XBLIU0F" & @CRLF & _
"H92UX8N" & @CRLF & _
"GUGQUKQ" & @CRLF & _
"PY2NFZ0" & @CRLF & _
"4Q7OGZP" & @CRLF & _
"Z5VGDWY" & @CRLF & _
"X0E 0G0" & @CRLF & _
"YEAJD6D" & @CRLF & _
"R6M 0A4" & @CRLF & _
"8H3UBVS" & @CRLF & _
"317HCXF" & @CRLF & _
"FWDF2UW" & @CRLF & _
"P40H72D" & @CRLF & _
"OWD3KVB" & @CRLF & _
"8IGB94X" & @CRLF & _
"JFLPI05" & @CRLF & _
"OCN91ZQ" & @CRLF & _
"XC8FMGC" & @CRLF & _
"0O1KOGN" & @CRLF & _
"684TESU" & @CRLF & _
"Y0WSZ15" & @CRLF & _
"RSKECBM" & @CRLF & _
"Y488MYL" & @CRLF & _
"DJLRJE2" & @CRLF & _
"GA6EI1D" & @CRLF & _
"C7U G3O" & @CRLF & _
"RV2C62C" & @CRLF & _
"XX1IFWW" & @CRLF & _
"S5EU716" & @CRLF & _
"K3R8V0P" & @CRLF & _
"L6NHJVQ" & @CRLF & _
"R45G9SH" & @CRLF & _
"O8W0UVF" & @CRLF & _
"FUX7H6P" & @CRLF & _
"5NUIL90" & @CRLF & _
"T4ACNYK" & @CRLF & _
"I3S5QWJ" & @CRLF & _
"LLSKBDS" & @CRLF & _
"5R7W88H" & @CRLF & _
"RUTNJXA" & @CRLF & _
"JEYRIN4" & @CRLF & _
"O62OG44" & @CRLF & _
"DAMW7YJ" & @CRLF & _
"ESC6IL0" & @CRLF & _
"85ZTRKO" & @CRLF & _
"LFN4LNG" & @CRLF & _
"7N4352T" & @CRLF & _
"DV5EG89" & @CRLF & _
"93OSFNO" & @CRLF & _
"50U33CF" & @CRLF & _
"J0SBCNC" & @CRLF & _
"Q77FUS0" & @CRLF & _
"ON2L7YC" & @CRLF & _
"GOVRTWB" & @CRLF & _
"BCN4RCL" & @CRLF & _
"RX2NTJW" & @CRLF & _
"99Q5M52" & @CRLF & _
"V4W 1C5" & @CRLF & _
"DH26PS0" & @CRLF & _
"J19CBEA" & @CRLF & _
"J0QDH03" & @CRLF & _
"D1X NOO" & @CRLF & _
"X0E 0V0" & @CRLF & _
"I7TXLJZ" & @CRLF & _
"53BNU19" & @CRLF & _
"MZEW2AX" & @CRLF & _
"6JFABO4" & @CRLF & _
"ZJG3J5D" & @CRLF & _
"X0E 0Z0" & @CRLF & _
"B4W4YMB" & @CRLF & _
"37UNJ9A" & @CRLF & _
"6R66IVX" & @CRLF & _
"5UQPTB9" & @CRLF & _
"R0G 0Y0" & @CRLF & _
"YF7JP8G" & @CRLF & _
"48XX1EL" & @CRLF & _
"WCUYX4I" & @CRLF & _
"762IWZ4" & @CRLF & _
"23NBY1L" & @CRLF & _
"3G6XU4P" & @CRLF & _
"GJVNEHC" & @CRLF & _
"X0E 0J0" & @CRLF & _
"B2HO1JN" & @CRLF & _
"CKU8PG7" & @CRLF & _
"TG2N6C9" & @CRLF & _
"KQO4T5I" & @CRLF & _
"6CXZ92J" & @CRLF & _
"WW0KB8J" & @CRLF & _
"SY5FC2W" & @CRLF & _
"XAZJKHA" & @CRLF & _
"2QGMNM4" & @CRLF & _
"0WI2R0U" & @CRLF & _
"X0E 0A0" & @CRLF & _
"8KW93VI" & @CRLF & _
"BTNXNDQ" & @CRLF & _
"2CY7493" & @CRLF & _
"D97IWVC" & @CRLF & _
"ME40FWL" & @CRLF & _
"EZZX50J" & @CRLF & _
"X0E 1L0" & @CRLF & _
"69JN5XN" & @CRLF & _
"G7OZFBG" & @CRLF & _
"GYF46SY" & @CRLF & _
"XD3VPQW" & @CRLF & _
"K5MWQB4" & @CRLF & _
"6LTEOO8" & @CRLF & _
"VAD9J5F" & @CRLF & _
"5GZARVT" & @CRLF & _
"E3ZY8D8" & @CRLF & _
"VWP9PCP" & @CRLF & _
"QREOACD" & @CRLF & _
"R0G 0C0" & @CRLF & _
"4B8394Q" & @CRLF & _
"R0G 0J0" & @CRLF & _
"V4W 1C3" & @CRLF & _
"3ZHVFCJ" & @CRLF & _
"1RFMTBM" & @CRLF & _
"DFCVUEW" & @CRLF & _
"5R7D8AT" & @CRLF & _
"RAHP4EF" & @CRLF & _
"5L45FTJ" & @CRLF & _
"XE1JZPD" & @CRLF & _
"PKTEPQ7" & @CRLF & _
"XDLSOVN" & @CRLF & _
"DIYPIK4" & @CRLF & _
"DI6JVL5" & @CRLF & _
"76QZC9V" & @CRLF & _
"LZ595ML" & @CRLF & _
"U4H9L7V" & @CRLF & _
"4SRWVWC" & @CRLF & _
"HGMZGKU" & @CRLF & _
"7SNFBJN" & @CRLF & _
"UG0DOTK" & @CRLF & _
"KH3UNP9" & @CRLF & _
"KBKMAY8" & @CRLF & _
"U1I95QA" & @CRLF & _
"Y379SYY" & @CRLF & _
"J7OAGHN" & @CRLF & _
"VE9IBPR" & @CRLF & _
"SADNELB" & @CRLF & _
"23CUB7K" & @CRLF & _
"PJ580EL" & @CRLF & _
"EZIUU2R" & @CRLF & _
"Q69N154" & @CRLF & _
"5WJ0KFU" & @CRLF & _
"3IW1XB3" & @CRLF & _
"0TPI8A7" & @CRLF & _
"3OUKYEQ" & @CRLF & _
"YRQWNYJ" & @CRLF & _
"K628FQ8" & @CRLF & _
"N4I3R5Z" & @CRLF & _
"CNGSW93" & @CRLF & _
"KDSIE58" & @CRLF & _
"4M041Z9" & @CRLF & _
"6ERUKDG" & @CRLF & _
"7V02JFY" & @CRLF & _
"JJO2659" & @CRLF & _
"2M6T5JY" & @CRLF & _
"O23AODX" & @CRLF & _
"V4W-1B7" & @CRLF & _
"6RGDNY9" & @CRLF & _
"4Q28NH3" & @CRLF & _
"XL5K6PV" & @CRLF & _
"X0E-0T0" & @CRLF & _
"ZE6NMO3" & @CRLF & _
"N3GQGF1" & @CRLF & _
"PN7I207" & @CRLF & _
"RTDYA1T" & @CRLF & _
"G8DEBKY" & @CRLF & _
"GRQPYCL" & @CRLF & _
"R0G 0B1" & @CRLF & _
"R0G 0V0" & @CRLF & _
"4S38X85" & @CRLF & _
"QF3DGDG" & @CRLF & _
"R0G 1H0" & @CRLF & _
"8UXUQ42" & @CRLF & _
"HUXFTN5" & @CRLF & _
"V77YGDP" & @CRLF & _
"1V3TMD1" & @CRLF & _
"JUGVD3E" & @CRLF & _
"9CU0UYP" & @CRLF & _
"77PV8GD" & @CRLF & _
"IN7450T" & @CRLF & _
"I4K1DVJ" & @CRLF & _
"P1ODTUX" & @CRLF & _
"FP71TWS" & @CRLF & _
"JF8NM06" & @CRLF & _
"UY6E4Q8" & @CRLF & _
"EJEH7OD" & @CRLF & _
"V4W 1A6" & @CRLF & _
"9PNLTCM" & @CRLF & _
"LG8HHPJ" & @CRLF & _
"SP4VDPY" & @CRLF & _
"73TWCLI" & @CRLF & _
"HB93P9P" & @CRLF & _
"BLSCGV6" & @CRLF & _
"DDJAU2B" & @CRLF & _
"23RMY67" & @CRLF & _
"CK2OVCM" & @CRLF & _
"UPC8706" & @CRLF & _
"T5VX87C" & @CRLF & _
"V4W 1C7" & @CRLF & _
"V2WAN42" & @CRLF & _
"R0G 0T0" & @CRLF & _
"HGZ0588" & @CRLF & _
"JT8GX26" & @CRLF & _
"2IQKV9Q" & @CRLF & _
"92QSQSM" & @CRLF & _
"S3I6CQ5" & @CRLF & _
"7LJSVTK" & @CRLF & _
"GT5PFMQ" & @CRLF & _
"L2I1E81" & @CRLF & _
"X099GUY" & @CRLF & _
"P5X8099" & @CRLF & _
"V4W 0A7" & @CRLF & _
"HKAJO79" & @CRLF & _
"SOCLKT7" & @CRLF & _
"4WYNHOK" & @CRLF & _
"SU05A4G" & @CRLF & _
"BRIUMJJ" & @CRLF & _
"5MX70VS" & @CRLF & _
"R0G 1E0" & @CRLF & _
"W5L0XE6" & @CRLF & _
"I3B9LMP" & @CRLF & _
"NCIIXAI" & @CRLF & _
"BAZRO7U" & @CRLF & _
"8U3T8IL" & @CRLF & _
"OLX0JQG" & @CRLF & _
"1JFA5H9" & @CRLF & _
"2KNXFL0" & @CRLF & _
"R6M 0A2" & @CRLF & _
"09LP9BP" & @CRLF & _
"9G2CD8P" & @CRLF & _
"UT96V7L" & @CRLF & _
"Y9TGDYM" & @CRLF & _
"BXBM4AG" & @CRLF & _
"65BHK2B" & @CRLF & _
"KW31STU" & @CRLF & _
"9KWT5ZS" & @CRLF & _
"X0E 1N0" & @CRLF & _
"THDX4GH" & @CRLF & _
"CYHCNSS" & @CRLF & _
"TILS0FE" & @CRLF & _
"KLSJNQU" & @CRLF & _
"029JF4T" & @CRLF & _
"3IIVD7J" & @CRLF & _
"XWV92SX" & @CRLF & _
"Z4WB33S" & @CRLF & _
"K6RXPCY" & @CRLF & _
"UKPNO5B" & @CRLF & _
"J2JIJ2I" & @CRLF & _
"C1O1B2C" & @CRLF & _
"7SXC9K5" & @CRLF & _
"JGJOG2Y" & @CRLF & _
"2BDQ4MZ" & @CRLF & _
"W6KS7KE" & @CRLF & _
"UL7DA6I" & @CRLF & _
"WEEXBD2" & @CRLF & _
"XORJDFL" & @CRLF & _
"BK9I7IN" & @CRLF & _
"WV0LAJK" & @CRLF & _
"J7GVG6Y" & @CRLF & _
"SNM4AI8" & @CRLF & _
"PDH6U4P" & @CRLF & _
"UROWD79" & @CRLF & _
"U7SDK3M" & @CRLF & _
"X0E 0K0" & @CRLF & _
"G92VTV2" & @CRLF & _
"YMJUGSY" & @CRLF & _
"F01DYMN" & @CRLF & _
"6ZNEPX4" & @CRLF & _
"Z9SXBXB" & @CRLF & _
"9FSXWX8" & @CRLF & _
"CF6SIMP" & @CRLF & _
"N8QKPVE" & @CRLF & _
"V4W 1C6" & @CRLF & _
"ZA55B0H" & @CRLF & _
"VMW7IUY" & @CRLF & _
"K0NL3I7" & @CRLF & _
"R66IH8L" & @CRLF & _
"BK8FTYG" & @CRLF & _
"LSSYTXM" & @CRLF & _
"DPP3EW3" & @CRLF & _
"V4W 0A6" & @CRLF & _
"O8TD058" & @CRLF & _
"LD0F8LQ" & @CRLF & _
"LI3TOEA" & @CRLF & _
"JQNH0V9" & @CRLF & _
"7CI0LM3" & @CRLF & _
"7SEFJH1" & @CRLF & _
"QK5PV2Z" & @CRLF & _
"4QNKDOZ" & @CRLF & _
"T6P8KL4" & @CRLF & _
"16YXV9F" & @CRLF & _
"0WQFFMR" & @CRLF & _
"D41BFC6" & @CRLF & _
"GT0N7VQ" & @CRLF & _
"NQCOM7Z" & @CRLF & _
"FXAYI5U" & @CRLF & _
"J8RJRCF" & @CRLF & _
"A5T2LZ8" & @CRLF & _
"49ABK7Q"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")