using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{3}[^\s-].{3}";
string input = @"E4A5Y8E
JQIU56G
S91ED8F
ZZ9850H
ZPPMYA9
J2OXGG0
X0E 0S0
9CF0ZJG
LTZTBLL
TEZPPN7
UD1UBM9
TII6VD6
BMZ90JF
VE6NLYJ
VACU01D
8SUDAFE
RQ8EFOI
08C97PD
3LB58FW
XQC2RW9
HEJ79FK
5FEJ81D
149EW6B
9KSPVLH
LTUNC3S
HN50KLO
8NXO6VL
4AZIQB8
U3L0TMV
044V0UG
EICE3TP
7Q7SC7Z
L86UAT3
JQYQLW0
MOEJCMZ
1AGVGOO
MPO18T0
QJMJ5TN
XJUEMLC
8JOANNN
0FIIIA1
QXZN03D
WAM 4BI
R0A 0S0
XUNFEAD
2KLDUOC
RHG NMK
M0P0XQS
D4J8MMC
X0E-1C0
J5L1KKU
EI2JTNY
BQ5LL52
1G6IL0L
JNF7KGE
1U1HSTG
OVJIO0H
U7X0ZTO
V98C18U
MNPDFAA
JRYV6I1
CSU29TX
2YLCS0E
IIPIOSN
V4W-1B9
U7HUEWN
AKUVDLL
IL2H9H3
G3ON4LY
V4W 1A4
UZSR5YK
SDC2A06
IEZJCH3
UABPVDJ
NBXDBQ5
17HR851
E1CZAGC
WFJ72DU
ANZ0JXG
YHA9M3X
HMDV5ER
S3PTFHM
ZZ6WYSA
IY99JD8
P7UVP4Z
NQ283P9
LELIDPT
R6M 0A5
R0G 0B2
9MI2DV0
MWACX9X
X0E 0H0
I7GHXN8
E063NU0
DLV7WF6
5ZTM1LL
QMEFANR
CYNVB4S
8W2LHCK
V4W 0A4
HCRQ4GZ
LIJCLYP
OECYFT4
V4W 1B6
7SRZUGW
VBUHQ3B
J5YST0B
R6M 0A3
0OQCULR
BG7JIMT
M0JFKE7
J6LAMJ9
WNRUDD1
7OOZITH
3ML8MD3
94IPNLE
W55SJH0
81XXMCE
97JZS9U
NXB31OU
Y4EDFZ1
9NGKXLW
JJ7X46J
CWU3CJM
8D9OYOP
3ZZV975
HTVJV1C
MENOU7S
SRKBGUN
0MONC6T
MS6O469
IUVOYQ9
25RDXZV
D99LO98
GKK3H2O
PDHJD5B
2KM3K5W
AJIIK4L
BD9A24I
UU32Y03
RCA4C86
0H4BBVG
8355956
V4W 1A7
RW9JLNP
ZQ2YMH0
71YCQRC
4ZUNJ7Q
152REQB
4NQR40P
6310AX1
3QC0AL6
8HN6COW
R5R1SW7
B8NPGEX
0ITC8M5
TE09NQX
DCDUSQU
61JDWMA
X0E 0B0
V4W 1A5
R0G 1C0
Z05290B
SDFDJB7
1AIQYRC
F5Q3TO4
ABWG8R7
8BHF4J5
176AKXX
U12T0US
6AO46QD
XQNEDH4
R0G 0B0
4HDUV2H
6M3F27U
900YSOA
QZKU6WK
O85SHCL
NG6K7CE
47BOY8N
7PU2R3W
2UQ CIC
1WJ7V4F
QKPWPZV
VHVVXJT
7YTZW6D
609X0LY
R6M 0A6
3QA1UTG
P4NP0VS
8RTG25F
2V7KTWW
31FC5QQ
R0G 0Z0
V4W 1B8
MZ337WC
6BM4ASC
QXSKH3R
I0Q63JL
73QEDO9
MIPJB4E
5211K66
4PVXK85
DN1NRBS
RCKEAST
8PAFPN0
AMDE4EM
5RX2U4F
CXC4HGU
UJZAE15
JMUL6Q6
VI7T9R4
SJF31CG
L5R8RQB
CQ74GTH
B5B26SC
V4W 1C8
002XEHG
UIVMXD3
59U220R
R6M-0A1
LASUZGV
9N984BZ
X0YAXJ7
NU55569
G6CMXRU
INI41IE
R0A 0L0
EDOLTZT
0ZJ2JOI
J1LFVQP
IBHW7BH
I7LMSXR
V4W 1A3
2OQJYMM
8TSW5J1
EQ6OIPV
34CVVKW
RCAY7SH
V4W 1A8
YSXBLN0
G26XHHE
V4W 0A5
DIBM8LW
T0E4Z3N
X031ZWH
Y33IVCB
S9R58C4
TC3Q07B
NBYVGSB
V4W 1C4
XBLIU0F
H92UX8N
GUGQUKQ
PY2NFZ0
4Q7OGZP
Z5VGDWY
X0E 0G0
YEAJD6D
R6M 0A4
8H3UBVS
317HCXF
FWDF2UW
P40H72D
OWD3KVB
8IGB94X
JFLPI05
OCN91ZQ
XC8FMGC
0O1KOGN
684TESU
Y0WSZ15
RSKECBM
Y488MYL
DJLRJE2
GA6EI1D
C7U G3O
RV2C62C
XX1IFWW
S5EU716
K3R8V0P
L6NHJVQ
R45G9SH
O8W0UVF
FUX7H6P
5NUIL90
T4ACNYK
I3S5QWJ
LLSKBDS
5R7W88H
RUTNJXA
JEYRIN4
O62OG44
DAMW7YJ
ESC6IL0
85ZTRKO
LFN4LNG
7N4352T
DV5EG89
93OSFNO
50U33CF
J0SBCNC
Q77FUS0
ON2L7YC
GOVRTWB
BCN4RCL
RX2NTJW
99Q5M52
V4W 1C5
DH26PS0
J19CBEA
J0QDH03
D1X NOO
X0E 0V0
I7TXLJZ
53BNU19
MZEW2AX
6JFABO4
ZJG3J5D
X0E 0Z0
B4W4YMB
37UNJ9A
6R66IVX
5UQPTB9
R0G 0Y0
YF7JP8G
48XX1EL
WCUYX4I
762IWZ4
23NBY1L
3G6XU4P
GJVNEHC
X0E 0J0
B2HO1JN
CKU8PG7
TG2N6C9
KQO4T5I
6CXZ92J
WW0KB8J
SY5FC2W
XAZJKHA
2QGMNM4
0WI2R0U
X0E 0A0
8KW93VI
BTNXNDQ
2CY7493
D97IWVC
ME40FWL
EZZX50J
X0E 1L0
69JN5XN
G7OZFBG
GYF46SY
XD3VPQW
K5MWQB4
6LTEOO8
VAD9J5F
5GZARVT
E3ZY8D8
VWP9PCP
QREOACD
R0G 0C0
4B8394Q
R0G 0J0
V4W 1C3
3ZHVFCJ
1RFMTBM
DFCVUEW
5R7D8AT
RAHP4EF
5L45FTJ
XE1JZPD
PKTEPQ7
XDLSOVN
DIYPIK4
DI6JVL5
76QZC9V
LZ595ML
U4H9L7V
4SRWVWC
HGMZGKU
7SNFBJN
UG0DOTK
KH3UNP9
KBKMAY8
U1I95QA
Y379SYY
J7OAGHN
VE9IBPR
SADNELB
23CUB7K
PJ580EL
EZIUU2R
Q69N154
5WJ0KFU
3IW1XB3
0TPI8A7
3OUKYEQ
YRQWNYJ
K628FQ8
N4I3R5Z
CNGSW93
KDSIE58
4M041Z9
6ERUKDG
7V02JFY
JJO2659
2M6T5JY
O23AODX
V4W-1B7
6RGDNY9
4Q28NH3
XL5K6PV
X0E-0T0
ZE6NMO3
N3GQGF1
PN7I207
RTDYA1T
G8DEBKY
GRQPYCL
R0G 0B1
R0G 0V0
4S38X85
QF3DGDG
R0G 1H0
8UXUQ42
HUXFTN5
V77YGDP
1V3TMD1
JUGVD3E
9CU0UYP
77PV8GD
IN7450T
I4K1DVJ
P1ODTUX
FP71TWS
JF8NM06
UY6E4Q8
EJEH7OD
V4W 1A6
9PNLTCM
LG8HHPJ
SP4VDPY
73TWCLI
HB93P9P
BLSCGV6
DDJAU2B
23RMY67
CK2OVCM
UPC8706
T5VX87C
V4W 1C7
V2WAN42
R0G 0T0
HGZ0588
JT8GX26
2IQKV9Q
92QSQSM
S3I6CQ5
7LJSVTK
GT5PFMQ
L2I1E81
X099GUY
P5X8099
V4W 0A7
HKAJO79
SOCLKT7
4WYNHOK
SU05A4G
BRIUMJJ
5MX70VS
R0G 1E0
W5L0XE6
I3B9LMP
NCIIXAI
BAZRO7U
8U3T8IL
OLX0JQG
1JFA5H9
2KNXFL0
R6M 0A2
09LP9BP
9G2CD8P
UT96V7L
Y9TGDYM
BXBM4AG
65BHK2B
KW31STU
9KWT5ZS
X0E 1N0
THDX4GH
CYHCNSS
TILS0FE
KLSJNQU
029JF4T
3IIVD7J
XWV92SX
Z4WB33S
K6RXPCY
UKPNO5B
J2JIJ2I
C1O1B2C
7SXC9K5
JGJOG2Y
2BDQ4MZ
W6KS7KE
UL7DA6I
WEEXBD2
XORJDFL
BK9I7IN
WV0LAJK
J7GVG6Y
SNM4AI8
PDH6U4P
UROWD79
U7SDK3M
X0E 0K0
G92VTV2
YMJUGSY
F01DYMN
6ZNEPX4
Z9SXBXB
9FSXWX8
CF6SIMP
N8QKPVE
V4W 1C6
ZA55B0H
VMW7IUY
K0NL3I7
R66IH8L
BK8FTYG
LSSYTXM
DPP3EW3
V4W 0A6
O8TD058
LD0F8LQ
LI3TOEA
JQNH0V9
7CI0LM3
7SEFJH1
QK5PV2Z
4QNKDOZ
T6P8KL4
16YXV9F
0WQFFMR
D41BFC6
GT0N7VQ
NQCOM7Z
FXAYI5U
J8RJRCF
A5T2LZ8
49ABK7Q";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}