#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\bword[12]\b)(?=.*\bword3\b)https?://example\.net/word\d.*$"
Local $sString = "https://example.ne" & @CRLF & _
"https://example.net/word3" & @CRLF & _
"https://example.net/word3/word2" & @CRLF & _
"https://example.net/word3/word1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")