const regex = new RegExp('^(?!.*\\bword[12]\\b)(?=.*\\bword3\\b)https?://example\\.net/word\\d.*$', 'gm')
const str = `https://example.ne
https://example.net/word3
https://example.net/word3/word2
https://example.net/word3/word1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}