#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\n|\s(?=Period))"
Local $sString = "Year: 2019 Period: 03" & @CRLF & _
"Office: NY" & @CRLF & _
"Dept: Sales" & @CRLF & _
"Acct: 111222333" & @CRLF & _
"SubAcct: 11122234-8" & @CRLF & _
"blahblahblahblahblahblahblah" & @CRLF & _
"Status: Pending"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)