import re
regex = re.compile(r"(\w+:\/\/[\w\.]+?\/([\w\.]+?)\/([\w\.]+?))\s", flags=re.MULTILINE)
test_str = ("1. https://github.com/ymcatwincities/openy_block_modal - Implements a simple block with a body and title that will be used to display modal windows.\n"
"1. https://github.com/ymcatwincities/openy_memberships - Membership Framework for OpenY and Drupal.\n"
"1. https://github.com/ymcatwincities/openy_prgf_sidebar_menu - SideBar menu for referencing menu blocks and using in SideBars across different pages.\n"
"1. https://packagist.org/packages/openy/openy_loc_finder - Extended Location Finder\n"
"1. https://github.com/Open-Y-subprojects/reqclique_gxp_sync - Reqclique Group Exercise Sync\n"
"1. https://github.com/open-y-subprojects/virtual_y_signaling_server - Signalling server for Virtual Y")
subst = "[$2/$3]($1) "
result = regex.sub(subst, test_str)
if result:
print(result)