import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\b(?:, ?)?(Apple|Bat|Car)\\b(?!.*?\\b\\1\\b)){3}$";
final String string = "Bat, Car, Apple\n"
+ "Car, Bat, Apple\n"
+ "Apple, Car, Bat\n"
+ "Apple, Car, Bat, Stick\n"
+ "Bat, Car\n"
+ "Apple\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}