$re = '/<(?!\/a>|a )[^>]+>/m';
$str = '<span>TEST1</span> <span>TEST2</span> <a href="#">TEST3</a>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;