re = /<(?!\/a>|a )[^>]+>/m
str = '<span>TEST1</span> <span>TEST2</span> <a href="#">TEST3</a>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result