package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{4}(\d{3})(\d{2}).{2}(.*)`)
var str = `JUNE5000950ABS20MN9G250GRN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}