$re = '/^.{4}(\d{3})(\d{2}).{2}(.*)/m';
$str = 'JUNE5000950ABS20MN9G250GRN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);