const regex = /(\d{3}\.[A-Za-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3}\\.[A-Za-z])', 'gm')
const str = `184.b189.a194.b199.d204.d209.b214.b219.d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}