$re = '/(\d{3}\.[A-Za-z])/m';
$str = '184.b189.a194.b199.d204.d209.b214.b219.d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);