const regex = /\bEmail:\s*([^\s@]+@[^\s@]+)(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bEmail:\\s*([^\\s@]+@[^\\s@]+)(?!\\S)', 'gm')
const str = `Details of Contact Made:
Sender's Name: Test (Individual)
Mobile: 4354354354
Email: 7c92e312-93d5-4354354-45435435@email.webhook.site
Message: I am interested in your property. Please get in touch with me
Click here
<https://www.magicbricks.com/bricks/mailerautologin.html?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}