# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bEmail:\s*([^\s@]+@[^\s@]+)(?!\S)"
test_str = ("Details of Contact Made: \n"
"Sender's Name: Test (Individual) \n"
"Mobile: 4354354354 \n"
"Email: 7c92e312-93d5-4354354-45435435@email.webhook.site\n"
"Message: I am interested in your property. Please get in touch with me \n"
"Click here \n"
"<https://www.magicbricks.com/bricks/mailerautologin.html?")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.