package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s*)?(\+)?([- _():=+]?\d[- _():=+]?){10,14}(\s*)?$`)
var str = `+79126819285`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}