$re = '/^([a-z]+) (and )?([a-z]+)?/im';
$str = 'apple and lemon
apple and
apple lemon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);