re = /^([a-z]+) (and )?([a-z]+)?/im
str = 'apple and lemon
apple and
apple lemon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end