import re
regex = re.compile(r"(?:.[.]\s+(.*?)(?=\n|$))", flags=re.MULTILINE)
test_str = ("1. 1x1s with David and Greg; research team meeting; non-IRS work; CTC-UP UT report; future UT planning\n"
"2. Sprint planning; CTC-UP UT Rd 2 planning meeting; 1x1 with Edward; weekly design sync; research touch-base with interns\n"
"3. no blockers")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")