const regex = /^((([A-Z]+\d*)(?!.*,\3\b)),)*[A-Z]+\d*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((([A-Z]+\\d*)(?!.*,\\3\\b)),)*[A-Z]+\\d*$', 'gm')
const str = `ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7
ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,ASAEW6
ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,
ASAEW1,ASAEW2,,ASA,S4,ASAEW5,ASAEW6,ASAEW7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}