$re = '/^((([A-Z]+\d*)(?!.*,\3\b)),)*[A-Z]+\d*$/m';
$str = 'ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7
ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,ASAEW6
ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,
ASAEW1,ASAEW2,,ASA,S4,ASAEW5,ASAEW6,ASAEW7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);