#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((([A-Z]+\d*)(?!.*,\3\b)),)*[A-Z]+\d*$"
Local $sString = "ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7" & @CRLF & _
"ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,ASAEW6" & @CRLF & _
"ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7," & @CRLF & _
"ASAEW1,ASAEW2,,ASA,S4,ASAEW5,ASAEW6,ASAEW7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")