re = /^((([A-Z]+\d*)(?!.*,\3\b)),)*[A-Z]+\d*$/m
str = 'ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7
ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,ASAEW6
ASAEW1,ASAEW2,ASA,S4,ASAEW5,ASAEW6,ASAEW7,
ASAEW1,ASAEW2,,ASA,S4,ASAEW5,ASAEW6,ASAEW7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end