#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<img(?!.*\s+alt\s*=).+$"
Local $sString = "<img src="smiley.gif" alt="Smiley face" height="42" width="42">" & @CRLF & _
"<img src="smiley2.gif" height="42" width="42">" & @CRLF & _
"<img src="smiley3.gif" alt="Smiley face Three" height="42" width="42">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")