re = /<img(?!.*\s+alt\s*=).+$/mi
str = '<img src="smiley.gif" alt="Smiley face" height="42" width="42">
<img src="smiley2.gif" height="42" width="42">
<img src="smiley3.gif" alt="Smiley face Three" height="42" width="42">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end