$re = '/(?:[^.]+\.){11}([^.]+)\.([^.]+)\.([^.]+)\.(?:[^.]+)/m';
$str = 'group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.error.count';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);