re = /(?:[^.]+\.){11}([^.]+)\.([^.]+)\.([^.]+)\.(?:[^.]+)/m
str = 'group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.error.count'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end