$re = '/(^50|^49)\d{8}/m';
$str = '4923456321
7725738388
5012345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);