using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http[^ \\n,]*/[^ \\n,\.]*";
string input = @"Adf adf asdf asdf asfdf https://.com/abcabcabc kdfja ladsjfladsjf ladksjf ladsjfl adsfadf adf asdf asdf asfdf https://.com/abcabcabc\n kdfja ladsjfladsjf ladksjf ladsjfl adsf https://.com/djflkajdsfl\n\n djldjfld djfladjf ldfdjlkfj ldfj.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}