$re = '/http[^ \\\\n,]*/[^ \\\\n,\.]*/m';
$str = 'Adf adf asdf asdf asfdf https://.com/abcabcabc kdfja ladsjfladsjf ladksjf ladsjfl adsfadf adf asdf asdf asfdf https://.com/abcabcabc\\n kdfja ladsjfladsjf ladksjf ladsjfl adsf https://.com/djflkajdsfl\\n\\n djldjfld djfladjf ldfdjlkfj ldfj.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);