$re = '/\[([a-zA-Z]{2})\].*?\[\/\1\]/mi';
$str = '[aa]My text[/AA][ab]Another Text[/ab]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);