re = /\[([a-zA-Z]{2})\].*?\[\/\1\]/mi
str = '[aa]My text[/AA][ab]Another Text[/ab]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end