#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Exception(?: in thread) "(?P<threadName>[^"]+)" (?P<changethenamelater>.*)\s+(?P<stackeTrace>(.|\n)*)"
Local $sString = "Exception in thread "main" java.lang.NullPointerException" & @CRLF & _
" at com.example.myproject.Book.getTitle(Book.java:16)" & @CRLF & _
" at com.example.myproject.Author.getBookTitles(Author.java:25)" & @CRLF & _
" at com.example.myproject.Bootstrap.main(Bootstrap.java:14)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")