using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Exception(?: in thread) ""(?P<threadName>[^""]+)"" (?P<changethenamelater>.*)\s+(?P<stackeTrace>(.|\n)*)";
string input = @"Exception in thread ""main"" java.lang.NullPointerException
at com.example.myproject.Book.getTitle(Book.java:16)
at com.example.myproject.Author.getBookTitles(Author.java:25)
at com.example.myproject.Bootstrap.main(Bootstrap.java:14)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}