#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\d{2,3}9\d+)(?<!\d)(\d{11,12})(?!\d)|(?<!\d)(\d{2}\s\d{5}\s\d{4})(?!\d)|(?<!\d)(0\d{2}\s\d{5}\s\d{4})(?!\d)|(?<!\d)(\d{2}\s9\s\d{4}\s\d{4})(?!\d)|(?<!\d)(0\d{2}\s9\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\d{9})(?!\d)|(?<!\d)(\d\s\d{8})(?!\d)|(?<!\d)(\(\d{2}\)\d{9})(?!\d)|(?<!\d)(\(0\d{2}\)\d{9})(?!\d)|(?<!\d)(\(\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\(0\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\(\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\(0\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)"
Local $sString = "---> DEVE ENCONTRAR:" & @CRLF & _
"11991234567 // /¯¯¯¯¯" & @CRLF & _
"011991234567 // | (?=\d{2,3}9\d+)(?<!\d)(\d{11,12})(?!\d)" & @CRLF & _
"119111111111 // \_____" & @CRLF & _
"11 99123 4567 // (?<!\d)(\d{2}\s\d{5}\s\d{4})(?!\d)" & @CRLF & _
"011 99123 4567 // (?<!\d)(0\d{2}\s\d{5}\s\d{4})(?!\d)" & @CRLF & _
"11 9 9123 4567 // (?<!\d)(\d{2}\s9\s\d{4}\s\d{4})(?!\d)" & @CRLF & _
"011 9 9123 4567 // (?<!\d)(0\d{2}\s9\s\d{4}\s\d{4})(?!\d)" & @CRLF & _
"" & @CRLF & _
"---> DEVE ENCONTRAR (EXEMPLOS DA PERGUNTA + ALGUMAS EXTENSÕES):" & @CRLF & _
"993345987 // (?<!\d)(\d{9})(?!\d)" & @CRLF & _
"9 93345987 // (?<!\d)(\d\s\d{8})(?!\d)" & @CRLF & _
"(21)932324343 // (?<!\d)(\(\d{2}\)\d{9})(?!\d) ## OU: (?<!\d)(\d{9})(?!\d)" & @CRLF & _
"(021)932324343 // (?<!\d)(\(0\d{2}\)\d{9})(?!\d) ## OU: (?<!\d)(\d{9})(?!\d)" & @CRLF & _
"(21)9 3232 4343 // (?<!\d)(\(\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)" & @CRLF & _
"(021)9 3232 4343 // (?<!\d)(\(0\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)" & @CRLF & _
"(21) 9 3232 4343 // (?<!\d)(\(\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)" & @CRLF & _
"(021) 9 3232 4343 // (?<!\d)(\(0\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NÃO DEVE ENCONTRAR:" & @CRLF & _
"11 99123 45671" & @CRLF & _
"111 99123 4567" & @CRLF & _
"011 99123 45678" & @CRLF & _
"811 99123 45678" & @CRLF & _
"a9999999999999999999989999123" & @CRLF & _
"118111111111" & @CRLF & _
"123456789123456789" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")