import Foundation
let pattern = #"(?=\d{2,3}9\d+)(?<!\d)(\d{11,12})(?!\d)|(?<!\d)(\d{2}\s\d{5}\s\d{4})(?!\d)|(?<!\d)(0\d{2}\s\d{5}\s\d{4})(?!\d)|(?<!\d)(\d{2}\s9\s\d{4}\s\d{4})(?!\d)|(?<!\d)(0\d{2}\s9\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\d{9})(?!\d)|(?<!\d)(\d\s\d{8})(?!\d)|(?<!\d)(\(\d{2}\)\d{9})(?!\d)|(?<!\d)(\(0\d{2}\)\d{9})(?!\d)|(?<!\d)(\(\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\(0\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\(\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)|(?<!\d)(\(0\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
---> DEVE ENCONTRAR:
11991234567 // /¯¯¯¯¯
011991234567 // | (?=\d{2,3}9\d+)(?<!\d)(\d{11,12})(?!\d)
119111111111 // \_____
11 99123 4567 // (?<!\d)(\d{2}\s\d{5}\s\d{4})(?!\d)
011 99123 4567 // (?<!\d)(0\d{2}\s\d{5}\s\d{4})(?!\d)
11 9 9123 4567 // (?<!\d)(\d{2}\s9\s\d{4}\s\d{4})(?!\d)
011 9 9123 4567 // (?<!\d)(0\d{2}\s9\s\d{4}\s\d{4})(?!\d)
---> DEVE ENCONTRAR (EXEMPLOS DA PERGUNTA + ALGUMAS EXTENSÕES):
993345987 // (?<!\d)(\d{9})(?!\d)
9 93345987 // (?<!\d)(\d\s\d{8})(?!\d)
(21)932324343 // (?<!\d)(\(\d{2}\)\d{9})(?!\d) ## OU: (?<!\d)(\d{9})(?!\d)
(021)932324343 // (?<!\d)(\(0\d{2}\)\d{9})(?!\d) ## OU: (?<!\d)(\d{9})(?!\d)
(21)9 3232 4343 // (?<!\d)(\(\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)
(021)9 3232 4343 // (?<!\d)(\(0\d{2}\)\d{1}\s\d{4}\s\d{4})(?!\d)
(21) 9 3232 4343 // (?<!\d)(\(\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)
(021) 9 3232 4343 // (?<!\d)(\(0\d{2}\)\s\d{1}\s\d{4}\s\d{4})(?!\d)
NÃO DEVE ENCONTRAR:
11 99123 45671
111 99123 4567
011 99123 45678
811 99123 45678
a9999999999999999999989999123
118111111111
123456789123456789
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)