#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)(?:^recipeingredient:\s\[\".*|\G)[^\"]*\K\\"
Local $sString = "description: "Easiest Way to Prepare Speedy Dal Chicken"" & @CRLF & _
"title: "How to Prepare Award-winning Dal Chicken"" & @CRLF & _
"date: 2020-12-10T07:38:14.079Z" & @CRLF & _
"image: https://img-\global.cpcdn.com/recipes/f92bd4e2e07d9fa1/751x532cq70/dal-chicken-recipe-main-photo.jpg" & @CRLF & _
"thumbnail: https://img-global.cpcdn.com/recipes/f92bd4e2e07d9fa1/751x532cq70/dal-chicken-recipe-main-photo.jpg" & @CRLF & _
"cover: https://img-global.cpcdn.com/recipes/f92bd4e2e07d9fa1/751x532cq70/dal-chicken-recipe-main-photo.jpg" & @CRLF & _
"author: Mathilda Day" & @CRLF & _
"ratingvalue: 4.9" & @CRLF & _
"reviewcount: 44224" & @CRLF & _
"recipeingredient: ["1 chicken breast - cut in small pieces","1 \ 1/2 cup chana dal - soaked over night and partially boiled","1 tblsp red chilli powder","1 tblsp dhaniya powder","pinch turmeric powder","1 1/2 tblsp of ginger-garlic paste"," Salt per taste","3 black peppers (whole)","3,4 cloves","1 cinnamon stick","1/2 tsp cumin seeds","1 medium onion - finely chopped","1 medium tomato paste","4 tblsp oil","as needed Water",]" & @CRLF & _
"recipeinstructions: ["Heat oil in a wok - Add cumin seeds, black peppers, cloves, and cinnamon stick.","Add onions.Let it cook till it turns light brownAdd tomato paste.Let it cook till oil separates.","Add lal masala (Step 3) & salt - Cook till oil separates and the masala is cooked.Add chicken and chana dal.Add water as needed.","Cook till chicken and the dal has properly cooked and the gravy is at the consistency that you want.","Serve with roti aur chapati.",]" & @CRLF & _
"categories:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")