const regex = /(?m)(?:^recipeingredient:\s\[\".*|\G)[^\"]*\K\\/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?:^recipeingredient:\\s\\[\\".*|\\G)[^\\"]*\\K\\\\', 'gm')
const str = `description: "Easiest Way to Prepare Speedy Dal Chicken"
title: "How to Prepare Award-winning Dal Chicken"
date: 2020-12-10T07:38:14.079Z
image: https://img-\\global.cpcdn.com/recipes/f92bd4e2e07d9fa1/751x532cq70/dal-chicken-recipe-main-photo.jpg
thumbnail: https://img-global.cpcdn.com/recipes/f92bd4e2e07d9fa1/751x532cq70/dal-chicken-recipe-main-photo.jpg
cover: https://img-global.cpcdn.com/recipes/f92bd4e2e07d9fa1/751x532cq70/dal-chicken-recipe-main-photo.jpg
author: Mathilda Day
ratingvalue: 4.9
reviewcount: 44224
recipeingredient: ["1 chicken breast - cut in small pieces","1 \\ 1/2 cup chana dal - soaked over night and partially boiled","1 tblsp red chilli powder","1 tblsp dhaniya powder","pinch turmeric powder","1 1/2 tblsp of ginger-garlic paste"," Salt per taste","3 black peppers (whole)","3,4 cloves","1 cinnamon stick","1/2 tsp cumin seeds","1 medium onion - finely chopped","1 medium tomato paste","4 tblsp oil","as needed Water",]
recipeinstructions: ["Heat oil in a wok - Add cumin seeds, black peppers, cloves, and cinnamon stick.","Add onions.Let it cook till it turns light brownAdd tomato paste.Let it cook till oil separates.","Add lal masala (Step 3) & salt - Cook till oil separates and the masala is cooked.Add chicken and chana dal.Add water as needed.","Cook till chicken and the dal has properly cooked and the gravy is at the consistency that you want.","Serve with roti aur chapati.",]
categories:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}