# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b0(?!9*~)|([0-9])(?=9*~[0-9]*?\1([0-9]))|~[0-9]*/$2/g;t' <<< "01~01234567890"