const regex = /\b0(?!9*~)|([0-9])(?=9*~[0-9]*?\1([0-9]))|~[0-9]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0(?!9*~)|([0-9])(?=9*~[0-9]*?\\1([0-9]))|~[0-9]*', 'g')
const str = `01~01234567890`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);