re = /(\w+)=/
str = '"a:link": "<a href=\\"http://|\\">",
"a:mail": "<a href=\\"mailto:|\\">",
"abbr": "<abbr title=\\"\\">",
"acr|acronym": "<acronym title=\\"\\">",
"base": "<base href=\\"\\" />",
"basefont": "<basefont/>",
"br": "<br/>",
"frame": "<frame/>",
"hr": "<hr/>",
"bdo": "<bdo dir=\\"\\">",
"bdo:r": "<bdo dir=\\"rtl\\">",
"bdo:l": "<bdo dir=\\"ltr\\">",
"col": "<col/>",
"link": "<link rel=\\"stylesheet\\" href=\\"\\" />"'
subst = 'what => '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result