const regex = /\<\d+\>\d+:\s:\s:\s\d+:\s(?<hostname>[^:]*):/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<\\d+\\>\\d+:\\s:\\s:\\s\\d+:\\s(?<hostname>[^:]*):', 'g')
const str = `<187>4265: : : 3147: full.qualified.domainname: Jan 20 2017 08:50:11.151 UTC : %UC_CALLMANAGER`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}