$re = '/\<\d+\>\d+:\s:\s:\s\d+:\s(?<hostname>[^:]*):/';
$str = '<187>4265: : : 3147: full.qualified.domainname: Jan 20 2017 08:50:11.151 UTC : %UC_CALLMANAGER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);