package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S(.{0,18}\S)?$`)
var str = `(Gebäude A)
Haus 1
auch `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}