$re = '/^\S(.{0,18}\S)?$/m';
$str = '(Gebäude A)
Haus 1
auch ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);