import Foundation
let pattern = #"[^@]{2,64}@[^.]{2,253}\.[0-9a-z-.]{2,63}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"name@anywhere.something"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}